Windows 部署服务更新

可以使用 Microsoft® Windows® 部署服务从 Windows 映像 (WIM) 文件安装 Windows® 操作系统。Windows 部署服务有助于进行基本配置，包括：

  • 对物理媒体进行分区和格式设置。

  • 安装操作系统并执行配置后任务。

  • 简化安装。

  • 提供整个计算机环境的一致性。

还可以使用 Windows 部署服务为现有计算机重新安装操作系统。

有关部署 Microsoft® Windows Vista™ 操作系统的详细信息，请参阅“可供 IT 专业人员使用的 Windows Vista 资源”(http://go.microsoft.com/fwlink/?LinkID=53518)。

  • Windows 部署服务更新概述

  • 检查表：安装和配置 Windows 部署服务更新

  • 检查表：创建自定义安装映像

  • 安装和卸载 Windows 部署服务更新

  • 配置 Windows 部署服务

  • 管理 Windows 部署服务服务器

  • 管理 Windows 部署服务客户端

  • 管理 Windows 映像

  • Windows 部署服务疑难解答

  • Windows 部署服务的资源


Windows 部署服务更新概述

Windows 部署服务专供负责在大中型组织中部署新计算机的管理员使用。如果您仅打算安装少量的计算机，请参阅“部署 Windows Vista”(http://go.microsoft.com/fwlink/?LinkId=71130)。

通过 Windows 部署服务，您可以执行下列操作：

  • 管理映像和无人参与安装脚本。

  • 提供需人参与和无人参与安装选项。

使用 Windows 部署服务的 IT 专业人员应熟悉下列内容：

  • Active Directory® 目录服务和动态主机配置协议 (DHCP) 概念。

  • Windows 预安装环境 (Windows PE)。

  • Windows 预启动执行环境 (PXE)。

  • Windows 映像 (WIM) 文件格式。

以下几节将介绍 Windows 部署服务，包括服务器、客户端、管理组件、部署要求和新增功能。

  • Windows 部署服务简介

  • Windows 部署服务的要求

  • Windows 部署服务中的新增功能

Windows 部署服务简介

Windows 部署服务包含一个 PXE 服务器和一个普通文件传输协议 (TFTP) 服务器。此外，Windows 部署服务还包含一个客户端界面和一个管理单元。

服务器组件

服务器组件包含用于网络启动客户端的 PXE 服务器和 TFTP 服务器，其目的是加载并最终安装操作系统。它还包括一个共享文件夹和映像储存库，其中包含网络启动所特别需要使用的启动映像、安装映像及文件。

客户端组件

客户端组件包括一个图形用户界面 (GUI)，它在 Windows PE 中运行，并与服务器组件通信以选择和安装操作系统映像。

管理组件

管理组件包括 Windows 部署服务管理 Microsoft 管理控制台 (MMC) 管理单元和命令行工具，它们可用于管理服务器、操作系统映像和客户端计算机帐户。

Windows 部署服务的优点

Windows 部署服务可使要部署 Windows 操作系统的企业在以下方面中获益：

  • 降低与手动安装过程效率低下相关联的成本。

  • 提高操作系统和应用程序的性能一致性。

  • 与手动安装相比，减少向咨询台的呼叫次数。

  • 减少用户安装新操作系统和常用应用程序所需的时间。

Windows 预安装环境

Windows 部署服务使用 Windows 预安装环境 (Windows PE) 提供客户端启动服务。Windows 部署服务客户端使用 Windows PE 提供可用安装映像的易用菜单，并提供与 Windows 安装程序一致的安装体验。

Windows 部署服务的要求

无论服务器还是客户端计算机，Windows 部署服务都未提出任何 RAM 或 CPU 速度要求。Windows 部署服务服务器需要使用 NTFS 文件系统分区，并为映像存储提供足够的磁盘空间，以容纳所有必需的映像。

操作系统要求

下列操作系统支持 Windows 部署服务：

  • Windows Server“Longhorn”

  • Windows Server 2003 Service Pack 1 (SP1)

    注意

    当前已推出适于 Windows Server 2003 SP1 的 Windows 部署服务更新包。必须安装远程安装服务 (RIS)，但无需对其进行配置。

  • Windows Server 2003 Service Pack 2 (SP2)

    注意

    如果已安装 RIS，Windows Server 2003 SP2 将默认安装 Windows 部署服务。

环境要求

部署 Windows 部署服务的环境必须满足下列要求：

  • Windows 部署服务服务器必须是 Active Directory 域的成员。

  • 必须具有 DHCP 才能使用 PXE 启动计算机。

Windows 部署服务中的新增功能

用于 Windows Server“Longhorn” 的 Windows 部署服务包含对远程安装服务 (RIS) 功能的多项修改。这些修改支持部署 Microsoft Windows Vista 和 Windows Server“Longhorn” 操作系统。这些更改包括如下内容：

  • 对 Windows PE 作为启动操作系统的内在支持。

  • 对 WIM 格式的内在支持。

  • 一个具有高性能的可扩展 PXE 服务器组件。

  • 一个用于选择启动操作系统的新的启动菜单格式。

  • 一个新的图形用户界面 (GUI)，可用于选择和部署映像以及管理 Windows 部署服务服务器和客户端。

其他参考

  • 部署 Windows Vista (http://go.microsoft.com/fwlink/?LinkId=71130)


检查表：安装和配置 Windows 部署服务更新

下列参考提供有关如何为环境正确安装和配置 Windows 部署服务的信息。

任务 | 参考
了解有关 Windows 部署服务的信息。 | Windows 部署服务更新概述
安装 Windows 部署服务。 | 安装 Windows 部署服务更新
为环境配置 Windows 部署服务。 | 配置 Windows 部署服务
向 Windows 部署服务管理单元添加服务器。 | 向 Windows 部署服务管理单元添加服务器
向 Windows 部署服务服务器添加映像。 | 添加映像
验证或设置 Windows 部署服务服务器的属性。 | 管理服务器属性
配置 Windows 部署服务的客户端设置。 | 管理 Windows 部署服务客户端


检查表：创建自定义安装映像

可以创建自定义映像，使其包含环境或特定用户组中常用的应用程序。还可以自动处理安装的多个方面，并将一个或多个语言包与映像关联在一起，而无需为每种语言都创建单独的映像。

任务 | 参考
创建捕获映像。 | 创建映像
为环境创建自定义安装映像。 | 创建映像
修改安装映像。 | 修改映像
为自定义映像创建映像组。 | 映像组
将映像添加到 Windows 部署服务服务器。 | 添加映像
启用映像的无人参与安装选项。 | 无人参与安装文件
将一个或多个语言包与映像关联 | 语言包


安装和卸载 Windows 部署服务更新

可以从 Windows 资源管理器或命令提示符处安装 Windows 部署服务更新。若要卸载 Windows 部署服务更新，请使用控制面板中的“添加或删除程序”。

  • 安装 Windows 部署服务更新

  • 卸载 Windows 部署服务更新


安装 Windows 部署服务更新

在运行 Windows Server 2003 Service Pack 1 (SP1) 且安装有远程安装服务 (RIS) 的服务器上可以使用更新包安装 Windows 部署服务。无需配置 RIS 即可安装该更新包。默认情况下，Windows 部署服务更新随 Windows Server 2003 Service Pack 2 (SP2) 一起安装。

  • 使用 Windows 资源管理器

  • 在命令提示符处

使用 Windows 资源管理器

使用 Windows 资源管理器安装 Windows 部署服务

  1. 使用 Windows 资源管理器，浏览本地或网络共享以找到该更新包。

  2. 双击适用于服务器体系结构和已安装的操作系统的“windows-deployment-services-update.exe”，将启动安装过程。

    注意

    如果显示“安全警告”页，请单击“运行”。

  3. 在“软件更新安装向导”起始页上，遵从所有建议，然后单击“下一步”继续。

  4. 在“Microsoft 软件许可条款”页上，单击“我同意”，然后单击“下一步”。

  5. 在“软件更新安装向导”完成页上，单击“完成”以重新启动计算机。

    注意

    如果不希望重新启动，请在单击“完成”之前单击“现在不重新启动”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 如果试图升级的系统不满足最低要求，将出现“安装失败”页。如果出现此页面，请记下失败的原因并采取相应的补救措施，然后再次运行更新包。

  • 如果要升级的系统不满足推荐的最低要求，将出现“安装警告”页。请记下推荐的操作，并在升级完成时采取推荐的补救措施。单击“下一步”继续。

  • 安装和卸载 Windows 部署服务更新

在命令提示符处

从命令提示符处安装 Windows 部署服务更新

  1. 切换至包含更新包的文件夹。

  2. 在命令提示符处，针对计算机的体系结构和操作系统体系结构，键入 windows-deployment-services-update /quiet /forcerestart。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 安装和卸载 Windows 部署服务更新

Windows 部署服务更新的安装选项

可以使用下列命令行选项来修改默认的更新行为，以满足安装方案的要求。

选项 | 目的
/help | 在命令行处使用此选项可列出下面的选项。
/quiet | 如果在安装期间不需要进行用户交互和显示信息，请使用此选项。
/passive | 如果不需要用户交互但希望显示状态栏来监控安装进度，请使用此选项。
/norestart | 使用此选项可取消安装结束后的重新启动操作。
/forcerestart | 如果要确保在安装完成后重新启动，请使用此选项。
/warnrestart[:<秒数>] | 在安装完成后，如果希望在重新启动计算机之前发出警告，请使用此选项。如果未提供任何参数，则使用默认设置，即在重新启动之前 30 秒向您发出警告。
/promptrestart | 如果希望提示您是否需要重新启动，请使用此选项。
/overwriteoem | 如果要覆盖现有的原始设备制造商 (OEM) 目录并删除这些目录中的现有文件，请使用此选项。
/nobackup | 如果不希望备份卸载 Windows 部署服务所需的文件，请使用此选项。
/forceappsclose | 如果要关闭可能阻止计算机重新启动的其他应用程序，请选择此选项。
/integrate:<完整路径> | 使用此选项可将软件更新与 Windows 部署服务一起安装。
/log:<完整路径> | 使用此选项可在指定的路径中创建一个日志文件。


卸载 Windows 部署服务更新

可通过控制面板中的“添加或删除程序”删除 Windows 部署服务更新。删除 Windows 部署服务时，将保留现有的远程安装服务 (RIS) 设置，此外，在 Windows 部署服务配置期间创建的任何共享、目录和映像也将保持不变。

若要删除 Windows 部署服务更新

  1. 单击“开始”，单击“控制面板”，然后单击“添加或删除程序”。

  2. 选择“适用于 Windows Server 2003 的 Windows 部署服务更新”。

  3. 单击“删除”。

  4. 在“Windows 部署服务删除向导”上，单击“下一步”。

  5. 在“完成”页上，单击“完成”。
注意

如果不希望在删除 Windows 部署服务后立即重新启动，请在单击“完成”之前单击“现在不重新启动”。

  1. 重新启动计算机后，Windows 部署服务更新将被删除。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 安装和卸载 Windows 部署服务更新


配置 Windows 部署服务

本节内容：

  • Windows 部署服务功能模式

  • 配置 Windows 部署服务

  • 配置 Windows 部署服务的 DHCP

Windows 部署服务功能模式

Windows 部署服务支持以下三种操作模式。

旧版模式

Windows 部署服务旧版模式与远程安装服务 (RIS) 在功能上等效。在此模式下，将仅显示 OSChooser 为启动操作系统，并且仅支持 RISETUP 和 RIPREP 映像。将不使用新增的 Windows 部署服务管理工具，旧版 RIS 实用程序将是管理服务器的唯一方式。旧版 Windows 部署服务模式通过安装 Windows 部署服务更新但不配置 Windows 部署服务（通过安装向导或在命令提示符处使用 WDSUTIL）来实现。仅 Windows Server 2003 支持旧版模式。

混合模式

Windows 部署服务混合模式描述了一种同时支持旧版 RIS 和新 Windows 部署服务功能的服务器状态。在混合模式下，可以使用 OSChooser 菜单和 Windows PE 启动映像。在此模式下，可以通过 OSChooser 访问 RISETUP 和 RIPREP 的旧映像类型，并可以通过利用 Windows PE 启动映像（Windows 部署服务客户端的 Windows Vista™ PE 启动映像）访问新的 WIM 格式映像。从客户端的角度来看，使用启动菜单可选择进入 RIS 或 Windows Server® 代号“Longhorn” Windows PE。从可管理性角度看，管理员将使用旧版管理工具管理 RISETUP 和 RIPREP 映像，同时使用新的 Windows 附属服务工具管理服务器和 WIM 映像。Windows 部署服务混合模式只能存在于 Windows Server 2003 中，并只能通过以下方式实现：在以前配置的 RIS 服务器上安装 Windows 部署服务更新，然后使用安装向导或在命令提示符处使用 WDSUTIL 来配置 Windows 部署服务。

本机模式

Windows 部署服务本机模式描述了仅带有 Windows PE 启动映像的 Windows 部署服务服务器。在此模式下，不会出现 OSChooser，并且 WIM 映像是部署到客户端时唯一受支持的映像类型。服务器的管理将完全在新的 Windows 部署服务管理工具中进行。Windows 部署服务本机模式可存在于 Windows Server 2003 和 Windows Server“Longhorn” 上。在 Windows Server“Longhorn” 上，这是唯一受支持的 Windows 部署服务模式。若要在运行 Windows Server 2003 的服务器上实现本机模式操作，请安装但不要配置 RIS，然后安装并配置 Windows 部署服务。还可以通过运行 WDSUTIL /set-server /ForceNative 强制服务迁移到本机模式。

Windows 部署服务功能模式的升级路径

功能 | 操作系统 | 步骤
本机模式：仅安装新的 WIM。 | Windows Server“Longhorn” | 安装并配置 Windows 部署服务服务器角色。
本机模式：仅安装新的 WIM。 | Windows Server 2003 | 安装但不配置 RIS。 安装并配置 Windows 部署服务更新，或安装 SP2 并配置 Windows 部署服务。
本机模式：仅安装新的 WIM | Windows Server 2003 | 删除现有的 RIS 安装。 安装但不配置 RIS。 安装并配置 Windows 部署服务更新，或安装 SP2 并配置 Windows 部署服务。
混合模式：安装 WIM 和现有的 RIS 映像。 | Windows Server 2003 | 在现有 RIS 服务器上安装 Windows 部署服务更新或 SP2 并配置 Windows 部署服务。
旧版模式：仅安装现有的 RIS 映像。 | Windows Server 2003 | 在现有 RIS 服务器上安装但不配置 Windows 部署服务更新或 SP2，并且不配置 Windows 部署服务。

配置 Windows 部署服务

可以使用下列过程之一执行 Windows 部署服务的初始配置：

  • 使用 Windows 部署服务安装向导。

  • 在命令行使用 WDSUTIL。

使用 Windows 部署服务安装向导配置 Windows 部署服务

  1. 若要打开 Windows 部署服务管理单元，请单击“开始”，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 在 Windows 部署服务管理单元的左窗格中，右键单击服务器，然后单击“配置服务器”。

  3. 在 Windows 部署服务配置向导欢迎页面上，检查确定环境是否符合所列要求，然后单击“下一步”。

  4. 如果远程安装文件夹的路径，然后单击“下一步”。

  5. 如果选择在系统驱动器上安装 Windows 部署服务，将显示一条警告消息。单击“是”继续安装；单击“否”可选择新的安装位置（推荐）。

  6. 设置适于环境的应答策略，然后单击“完成”完成配置。

  7. 在 Windows 部署服务配置完成页面上，可以向服务器添加映像（默认设置），如果希望在其他时间添加映像，请取消选中“立即添加映像至 Windows 部署服务服务器”。

其他注意事项和参考

  • 如果基于 x64 的客户端的启动菜单上未显示 x64 映像，请在命令提示符处键入 WDSUTIL /set-server /autodiscovery:yes。

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派有正确的权限。

  • Windows 部署服务更新

从命令提示符处配置 Windows 部署服务

  1. 单击“开始”，指向“所有程序”，再指向“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示处，键入：WDSUTIL /initialize-server /reminst:driveletter\foldername（其中，driveletter 是 NTFS 格式的驱动器的名称，foldername 是要创建共享文件夹的目录名称），然后按 Enter。

  3. 若要将应答策略设置为应答所有的客户端，请键入：WDSUTIL /set-server /answerclients:all

    注意

    如果要在安装有 Microsoft DHCP 的系统上安装 Windows 部署服务，请键入：WDSUTIL /set-server /usedhcpports:no /DHCPoption60:yes。

  4. 若要添加启动映像，请键入：WDSUTIL /add-image /imagefile:\\server\share\sources\boot.wim /imagetype:boot，其中 path 是启动映像的完整路径。

  5. To add an install image, type:WDSUTIL /add-image /imagefile:\\server\share\sources\install.wim /imagetype:install，其中 path 是安装映像的完整路径。

其他注意事项和参考

  • 如果基于 x64 的客户端的启动菜单上未显示 x64 映像，请在命令提示符处键入 WDSUTIL /set-server /autodiscovery:yes。

  • 在命令提示处键入 WDSUTIL /? 可获得有关 WDSUTIL 的帮助。

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有提升的特权才能运行。

  • Windows 部署服务更新

配置 Windows 部署服务的 DHCP

Windows 部署服务需要在网络存在活动的动态主机配置协议 (DHCP) 服务器。Windows 部署服务依赖于预启动执行环境 (PXE)，这一环境反过来又依赖于 DHCP。如果将 Windows 部署服务和 DHCP 安装在一台服务器上，则需要更改为 DHCP 配置。

DHCP 选项 60

如果将 Microsoft DHCP 与 Windows 部署服务安装在同一台物理计算机上，则 Windows 部署服务配置向导将向所有 DHCP 作用范围添加 DHCP 选项标记 60 并选择 PXE 客户端设置（作为一项 DHCP 全局选项）。需要使用此选项，以便通知启动 PXE 客户端：网络上存在侦听 PXE 服务器。

配置 DHCP 选项 60

如果将 DHCP 服务添加到现有的 Windows 部署服务服务器，则需要手动重新配置 DHCP 选项 60。配置 DHCP 选项 60 时可使用两种过程：

  • 使用 Windows 部署服务管理单元配置 DHCP 选项 60。

  • 使用 WDSUTIL 配置 DHCP 选项 60。

使用 Windows 部署服务管理单元配置 DHCP 选项 60

  1. 单击“开始”，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 在 Windows 部署服务管理单元的左窗格中，单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 在“服务器属性”页，单击“DHCP”选项卡。

  5. 在“DHCP 选项”页上，单击“将 DHCP 选项 60 配置为‘PXEClient’”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派有正确的权限。

  • Windows 部署服务更新

使用 WDSUTIL 配置 DHCP 选项 60

  1. 依次单击“开始”、“所有程序”、“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符处，键入 WDSUTIL /set-server /DHCPOption60:yes

其他注意事项和参考

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有提升的特权才能运行。

  • Windows 部署服务更新

端口 67

如果将 Microsoft DHCP 服务与 Windows 部署服务安装在同一台物理计算机上，则 Windows 部署服务配置向导将通过选择“不侦听端口 67”选项来配置 Windows 部署服务。需要使用该选项，以便启动客户端可以找到网络上的 DHCP 服务器。

配置端口 67

  • 如果将 DHCP 服务添加到现有的 Windows 部署服务服务器，则需要重新配置端口 67。可以使用下列两个过程之一配置端口 67。

使用 Windows 部署服务管理单元配置端口 67

  1. 在“开始”菜单上，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 在“服务器属性”页上，单击“DHCP”选项卡。

  5. 在“DHCP 选项”页上，单击“不侦听端口 67”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派有正确的权限。

  • Windows 部署服务更新

使用 WDSUTIL 配置端口 67

  1. 单击“开始”，指向“所有程序”，再指向“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符处，键入 WDSUTIL /set-server /usedhcpports:no

其他注意事项和参考

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有提升的特权才能运行。

  • Windows 部署服务更新


管理 Windows 部署服务服务器

  • 向 Windows 部署服务管理单元添加服务器

  • 删除 Windows 部署服务管理单元中的服务器

  • 管理服务器属性


向 Windows 部署服务管理单元添加服务器

Windows 部署服务管理单元可对环境中的所有 Windows 部署服务服务器提供基于控制台的管理。若要管理 Windows 部署服务服务器，必须先将它们添加到 Windows 部署服务管理单元中。

向 Windows 部署服务管理单元添加服务器

  1. 若要打开 Windows 部署服务管理单元，请单击“开始”，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 右键单击“服务器”节点，然后单击“添加服务器”。

  3. 在“添加服务器”对话框中，单击以选择要添加的服务器，然后单击“确定”继续。

  4. 在“添加服务器警告”对话框中，单击“是”以添加服务器。

  5. 退出管理单元时，单击“是”以保存设置。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理 Windows 部署服务服务器


删除 Windows 部署服务管理单元中的服务器

可以使用以下过程从 Windows 部署服务管理单元中删除 Windows 部署服务服务器。

删除 Windows 部署服务管理单元中的服务器

  1. 若要打开 Windows 部署服务管理单元，请单击“开始”，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 单击以展开“服务器”列表。

  3. 右键单击要从控制台中删除的服务器。

  4. 单击“删除服务器”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理 Windows 部署服务服务器


管理服务器属性

可以使用 Windows 部署服务服务器的“服务器属性”页配置服务器操作的各个方面。

  • DHCP 属性

  • PXE 服务器属性

  • 常规属性

  • 目录服务属性

  • 启动属性

  • 客户端属性


DHCP 属性

Windows 部署服务的动态主机配置协议 (DHCP) 配置选项可在每台服务器的“DHCP 属性”页上设置，也可以在初始配置期间使用“Windows 部署服务配置向导”设置。

  • 配置 DHCP 选项 60

  • 配置端口 67

配置 DHCP 选项 60

Windows 部署服务的默认配置假设 Microsoft DHCP 服务器和 Windows 部署服务服务器位于单独的物理计算机上。当 DHCP 和 Windows 部署服务位于同一台计算机上时，DHCP 必须在 DHCP 提供数据包中包含 DHCP 选项 60，以此来通知客户端计算机存在侦听网络的 PXE 服务器。

使用 Windows 部署服务管理单元配置 DHCP 选项 60

  1. 在“开始”菜单上，单击“管理工具”，然后单击“Windows 部署服务”。

  2. 单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 在“服务器属性”页上，单击“DHCP”选项卡。

  5. 在“DHCP 选项”页上，单击“将 DHCP 选项 60 配置为‘PXEClient’”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理服务器属性

使用 WDSUTIL 配置 DHCP 选项 60

  • 在命令提示符处，键入：WDSUTIL /set-server /DHCPoption60:yes

其他注意事项和参考

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有高特权才能运行。

  • 管理服务器属性

配置端口 67

由于 DHCP 在默认情况下侦听端口 67，因此当 Windows 部署服务和 DHCP 存在于同一台计算机上时，Windows 部署服务 PXE 服务器将无法侦听端口 67 中传入的 PXE 启动请求。

使用 Windows 部署服务管理单元配置端口 67

  1. 在“开始”菜单上，选择“管理工具”，然后单击“Windows 部署服务”。

  2. 单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 在“服务器属性”页上，单击“DHCP”选项卡。

  5. 在“DHCP 选项”页上，单击“不侦听端口 67”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理服务器属性

在命令提示符处使用 WDSUTIL 配置端口 67

  • 在命令提示符处，键入：WDSUTIL /set-server /usedhcpports:no。

其他注意事项和参考

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有高特权才能运行。

  • 管理服务器属性

    要点

    如果 Microsoft DHCP 和 Windows 部署服务在同一台计算机上运行，则必须同时选择“将 DHCP 选项标记 #60 配置为 PXEClient”和“不侦听端口 67”选项。


PXE 服务器属性

PXE 服务器设置在“服务器属性”页的“PXE 响应设置”选项卡上设置。这些设置可决定 Windows 部署服务将响应哪些客户端、在响应未知客户端时采取的操作以及在响应客户端之前要等待的时间。可以根据需要修改以下策略：

  • PXE 响应策略

  • PXE 响应延迟

PXE 响应策略

此选项指定 Windows 部署服务 PXE 服务器是否应响应传入的客户端 PXE 请求。如果不选择此选项，任何客户端都将无法通过 PXE 启动到 Windows 部署服务服务器。

不响应任何客户端计算机。如果不希望服务器响应客户端请求，请使用此设置。

仅响应已知客户端计算机。在选择“响应客户端计算机策略”时，可以启用此选项。选择此选项时，需要在 Active Directory 中预留客户端。这些预留的客户端称为“已知”设备；未预留的客户端为“未知”设备，无法通过 PXE 启动到 Windows 部署服务。

响应所有(已知和未知)客户端计算机。选择此选项将允许所有客户端通过 PXE 启动到 Windows 部署服务服务器。

对于未知客户端，通知管理员并在批准后响应。如果要在允许新客户端接收来自 Windows 部署服务服务器的启动服务之前对其进行审批，请选择此选项以及“响应所有(已知和未知)客户端计算机”。

有关如何预留客户端计算机的详细信息，请参阅“Prestage client computers”（预留客户端计算机，http://go.microsoft.com/fwlink/?LinkId=50166）。

PXE 响应延迟

使用 PXE 响应延迟设置可调整服务器对网络上客户端的响应速度。PXE 响应延迟用于设置 PXE 服务器等待其他 PXE 服务器响应的时间，默认设置为零。除非网络上存在需要优先权的其他 PXE 响应服务器或网络需要延长 PXE 响应延迟，否则应将此设置保留为零。

其他资源

  • 管理服务器属性


常规属性

“常规”页包含下列信息：

  • 计算机名称。运行 Windows 部署服务的服务器的名称。

  • 远程安装位置。包含 Windows 操作系统映像的共享的名称。

  • 服务器模式。Windows 部署服务的操作模式。该模式可以是本机模式、混合模式或旧版模式。

    • 本机模式 - 当配置为纯模式时，Windows 部署服务仅支持 Windows 映像 (WIM) 文件格式和命令集。在本机模式下，Windows 部署服务不提供对 RIS 命令或映像的支持。

    • 混合模式 - 当配置为混合模式时，Windows 部署服务支持 RIS 以及本机命令集和映像类型。

    • 旧版模式 - 当配置为旧版模式时，Windows 部署服务仅支持 RIPREP 和 RISETUP 映像类型以及 RIS 命令集。

其他资源

  • 管理服务器属性


目录服务属性

新客户端命名策略和帐户位置

可以使用“目录服务属性”页设置默认客户端命名策略和计算机帐户位置。Windows 部署服务提供了四种方法用于命名计算机并将其置于组织单元中。

  • 管理员指定计算机名称和管理单元。

  • 服务器指定计算机名称和管理单元。

  • 客户端在首次启动时执行所有域加入活动。

  • 管理员创建自定义用户界面。

管理员指定计算机名称和组织单元

可以为计算机逐个指定计算机名称和要加入的组织单元。此方案需要启用挂起设备的自动添加策略，然后在计算机得到批准时使用 Windows 部署服务管理单元指定客户端名称和组织单元。可以通过两种方式使用这些设置：

  • 作为挂起设备审批过程的一部分。这些是根据服务器和体系结构进行的设置，且适用于所有已批准设备。管理员可以在批准设备时逐设备覆盖这些设置。

  • 用于涉及 WDS 客户端的域加入方案。默认情况下，使用 WDS 客户端进行的所有安装将使计算机在安装过程结束时加入到域中。如果在预留客户端（手动创建或通过“挂起设备”创建）上进行安装，则会将该客户端作为现有设备加入。如果在新计算机上进行安装，WDS 客户端将基于这些策略设置在 Active Directory 中创建计算机帐户。随后，该客户端将以该新建帐户的身份加入。

在审批期间指定客户端命名策略和组织单元

  1. 右键单击服务器，然后单击“属性”。

  2. 单击“PXE 响应设置”选项卡。

  3. 单击“响应所有(已知和未知)客户端计算机”。

  4. 单击“对于未知客户端，通知管理员并在批准后响应”。

  5. 通过 PXE 启动客户端计算机。

  6. 在客户端计算机上，您将看到一条消息，其中提供了客户端计算机在启动时所联系的服务器的请求 ID 和 IP 地址。

  7. 在 Windows 部署服务管理单元中的“挂起设备”下，选择客户端为查看新客户端而联系的服务器。

  8. 右键单击设备，然后单击“批准”。

  9. 键入计算机名称和组织单元。

  10. 单击“确定”。

  11. 在客户端计算机上，从菜单中选择一个映像，然后单击“输入”。

服务器指定计算机名称和管理单元

可以按服务器设置计算机名称和组织单元，随后，从给定服务器生成的所有客户端都将使用一致的计算机命名策略并置入同一域中。相应的设置在“服务器属性”选项卡中设置，当 Windows 部署服务客户端启动安装的第一个阶段时，将使用这些值。

按服务器指定客户端命名策略和组织单元

  1. 右键单击服务器，然后单击“属性”。

  2. 单击“PXE 响应设置”选项卡。

  3. 单击“响应所有(已知和未知)客户端计算机”。

  4. 单击“目录服务”选项卡。

  5. 设置客户端命名策略。

    注意

    默认客户端命名策略定义为用户名称后跟两个随机数字。可以使用数字 1–9 来更改用户名后面的数字位。

  6. 在“客户端帐户位置”下，选择默认（与 Windows 部署服务服务器所在的域相同）组织单元或为服务器定义默认的组织单元。

  7. 通过 PXE 启动客户端计算机并使用指定的客户端命名策略和组织单元来构建该计算机。

在首次启动时执行所有域加入操作

Windows 部署服务客户端会将域加入信息（包括计算机名称、域和用户凭据）添加到客户端安装期间所使用的映像无人参与安装文件中。如果现有的无人参与安装文件与客户端要安装的映像关联，则会更新无人参与安装文件。如果客户端要安装的映像不具有关联的无人参与安装文件，将使用“模板”无人参与安装文件。下级映像的无人参与安装模板位于“REMINST”共享的 \Templates 目录中。Windows Vista 和 Windows Server“Longhorn” 映像的无人参与安装模板位于映像本身中，它是 \Windows\system32\WdsUnattendFile.xml 。

如果您要使用映像无人参与安装文件，请确保该文件中包含正确标记：

  • <UnsecureJoin> 用于 Unattend.xml。

  • “DoOldStyleDomainJoin”用于 Sysprep.inf。

如果存在这些标记，则说明 WDS 应插入域加入信息。

无人参与文件的 <specialize> 段中必须具有 Microsoft-Windows-Shell-Setup 部分。只有当 <specialize> 中至少包含一个空的 Microsoft-Windows-Shell-Setup 部分时，才会添加计算机名称。这是为避免对此组件的属性（例如 publicKeyToken 和 language）进行硬编码。

创建自定义用户界面

还可以通过创建自定义用户界面在安装之前指定计算机名称和组织单元。例如，可以编写在 WinPE 中运行并捕获计算机名称或组织单元信息的脚本，将其置于无人参与安装文件中，然后调用 Setup.exe。如果需要带有附加插件的应用程序来提供此自定义级别，请参阅“Microsoft Solution Accelerator for Business Desktop Deployment 2007”(http://go.microsoft.com/fwlink/?LinkId=71137)。

其他注意事项

  • 若要执行这些过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

其他参考

  • Microsoft Solution Accelerator for Business Desktop Deployment 2007 (http://go.microsoft.com/fwlink/?LinkId=71137)

  • 示例无人参与安装文件

  • 管理服务器属性


启动属性

“Windows 部署服务启动属性”页允许按体系结构配置默认启动程序和默认启动映像。

  • 默认启动程序

  • 默认启动映像

默认启动程序

可以设置默认启动程序设置，以按体系结构定义 PXE 客户端与 WDS 服务器交互的方式。下表描述了可用的启动程序。

启动程序 功能

Abortpxe.com

当管理员拒绝挂起设备时，将向客户端计算机发送此程序。

Bootmgfw.efi

pxeboot.com 的 EFI 版本包含 pxeboot.com、pxeboot.n12、abortpxe.com 和 bootmgr.exe 中的所有功能。当前仅 ia64 提供此版本。

Hdlscom1.com

对于不支持将固件重定向到控制台的系统，使用此程序可以将固件输出重定向到其 COM1 端口。可按 F12 继续启动过程，或不按 F12 退出启动过程。

Hdlscom1.n12

对于不支持将固件重定向到控制台的系统，使用此程序可以将固件输出重定向到其 COM1 端口。此程序中无需使用 F12 键，而是直接启动进入 PXE 服务器。

Hdlscom2.com

对于不支持将固件重定向到控制台的系统，使用此程序可以将固件输出重定向到其 COM2 端口。可按 F12 继续启动过程，或不按 F12 退出启动过程。

Hdlscom2.n12

对于不支持将固件重定向到控制台的系统，使用此程序可以将固件输出重定向到其 COM2 端口。此程序中无需使用 F12 键，而是直接启动进入 PXE 服务器。

Pxeboot.com

可以使用此（默认）启动程序提示用户按 F12 键来访问启动服务。

Pxeboot.n12

使用此启动程序则无需按 F12 键而直接启动进入 PXE 服务器。

Wdsnbp.com

Wdsnbp.com 是 Windows 部署服务使用的网络启动程序，永远不能用作默认启动程序。Wdsnbp.com 用于以下常规目的：

  • 延迟 PXE 启动。这使 Windows 部署服务可以执行高级应答逻辑，而不会在等待服务器时发生客户端超时。

  • 当无法从 PXE 启动网络数据包中确定启动客户端的体系结构时，报告回这一信息。这在不能报告回其 64 位体系结构的 x64 系统上尤为有用。

  • 解决 Windows 部署服务和 RIS 位于同一网络或网段上时存在的 PXE 引用问题。

  • 充当自动添加事件的网络启动协议，其中，它将延迟 PXE 启动过程并轮询服务器的批准状态。

可以使用服务器的“启动属性”页或 WDSUTIL 来设置默认启动程序。

按服务器设置体系结构特定的默认启动程序

  1. 打开 Windows 部署服务管理单元。

  2. 单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 单击“启动”选项卡。

  5. 在“启动属性”页的“默认启动映像(可选)”下，找到要更改的体系结构，然后单击“浏览”。

  6. 通过单击选择适当的文件，然后单击“打开”。

  7. 单击“确定”。

  8. 如果出现警告，请验证您的选择是否正确，然后单击“是”。

默认启动映像

可以使用此选项按体系结构和按服务器指定默认映像。如果希望 x64 客户端始终收到 x64 系统映像，或要在映像中包含体系结构特定的工具，则可以执行此操作。

按服务器选择默认启动映像

  1. 打开 Windows 部署服务管理单元。

  2. 单击以展开“服务器”列表。

  3. 右键单击服务器，然后单击“属性”

  4. 单击“启动”选项卡。

  5. 在“启动属性”页的“默认启动映像(可选)”下，找到要更改的体系结构，然后单击“选择”。

  6. 在“浏览”对话框中，单击要用作默认映像的映像，然后单击“确定”。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理服务器属性


客户端属性

“Windows 部署服务客户端属性”页允许将客户端操作模式配置为需人参与或无人参与，并覆盖默认的客户端帐户创建。在无人参与模式下，将不显示决定映像选择和磁盘配置的 Windows 部署服务客户端页面，而是使用管理员提供的默认设置。

  • 启用客户端无人参与

  • 客户端帐户创建

启用客户端无人参与安装

从 Windows 部署服务管理单元启用客户端无人参与安装

  1. 打开 Windows 部署服务管理单元。

  2. 单击以展开服务器列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 单击“客户端”选项卡。

  5. 单击“启用无人参与安装”。

  6. 单击“浏览”按体系结构选择无人参与安装文件。

  7. 单击选择文件。

  8. 单击“确定”。
注意

最佳做法：将 Windows 部署服务客户端无人参与安装文件复制到 REMINST 共享下的 \WDSClientUnattend 文件夹中。

从命令提示符处启用客户端无人参与安装

  • 键入 WDSUTIL /Set-Server /WdsUnattend /Policy:Enabled /File:WDSClientUnattend \unattend.xml /Architecture:x86

客户端帐户创建

使用 Windows 部署服务管理单元禁用客户端帐户创建

  1. 打开 Windows 部署服务管理单元。

  2. 单击以展开服务器列表。

  3. 右键单击服务器，然后单击“属性”。

  4. 单击“客户端”选项卡。

  5. 单击以选择“运行 WDS 客户端后不在域中创建帐户”。
在命令提示符处使用 WDSUTIL 禁用客户端帐户创建

  • 键入 WDSUTIL /JoinDomain:No

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 在完成此过程之前，需要将客户端无人参与安装文件复制到 \Reminst\WDSClientUnattend 中。

  • 示例无人参与安装文件

  • 无人参与安装文件

  • 管理服务器属性


管理 Windows 部署服务客户端

可以使用以下信息来了解有关未知客户端策略、计算机命名和挂起设备文件夹的信息。

  • 预留客户端计算机

  • 设置计算机命名策略

  • 挂起设备


预留客户端计算机

通过预留客户端计算机，管理员可以将计算机分配给特定的 Windows 部署服务服务器。在与“仅响应已知客户端计算机”策略一起使用时，预留还允许控制使用 Windows 部署服务能部署哪些计算机。

Windows 部署服务为预留客户端计算机提供了自动化方法和手动方法。有关自动化方法的信息，请参阅挂起设备。

  • 使用 Windows 界面

  • 在命令提示符处

使用 Active Directory 用户和计算机预留计算机

使用 Windows 界面预留客户端计算机

  1. 若要打开“Active Directory 用户和计算机”，请单击“开始”，单击“运行”，键入 dsa.msc，然后单击“确定”。

  2. 在控制台树中，右键单击将包含新客户端计算机的组织单元。

  3. 单击“新建”，然后单击“计算机”。

  4. 键入客户端计算机名称，单击“下一步”，然后单击“这是一台被管理的计算机”。

  5. 在文本输入字段中，键入客户端计算机的全局唯一标识符 (GUID)，然后单击“下一步”。

  6. 单击下列选项之一，以指定将支持此客户端计算机的一台或多台服务器。

    • 任何可用的远程安装服务器

    • 以下的远程安装服务器

    注意

    选择第二个选项可指定要为此客户端计算机提供服务的特定服务器。

  7. 单击“下一步”，然后单击“完成”。

其他注意事项和参考

  • 若要执行这些过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 将计算机预留到具有多个域控制器的域中时，客户端计算机帐户信息的复制延迟将导致另一台 Windows 部署服务服务器为该客户端计算机提供服务。

  • 管理服务器属性

  • 挂起设备

使用 WDSUTIL 预留计算机

使用 WDSUTIL 预留客户端计算机

  • 键入 WDSUTIL /add-device /device:<devicename> /ID:<MACAddress> /options，其中 devicename 是名称，MACAddress 是新计算机的 MAC 地址，options 是任何可选设置。

其他注意事项和参考

  • WDSUTIL 是 Windows 部署服务命令行管理工具，需要有高特权才能运行。

  • 可以通过 Active Directory 用户和计算机以及通过 GUID 或 MAC 地址使用 WDSUTIL 来预留客户端计算机。如果使用了 MAC 地址，则必须在其前面添加二十个零“0”。

  • 将计算机预留到具有多个域控制器的域中时，客户端计算机帐户信息的复制延迟将导致另一台 Windows 部署服务服务器为该客户端计算机提供服务。

  • 管理服务器属性

  • 挂起设备


设置计算机命名策略

如果要确保为每台客户端计算机都给定唯一的计算机名，请从自动命名选项列表中进行选择。所有基于用户名的自动命名选项都会在名称末尾添加一个递增的数字，以确保计算机名称是唯一的。

请在下表中选择一个选项，以自动创建自定义的计算机名称。

变量 | 结果
%First | 将用户的名字用作计算机名称。
%Last | 将用户的姓氏用作计算机名称。
%Username | 将用户名用作计算机名称。
%MAC | 将网络适配器媒体访问控制 (MAC) 地址用作计算机名称。
%[0][n]# | 计算机名称中包含一个“n”位的递增数字。若要在递增数字中包含零填充，请按显示方式键入零。例如，如果您使用 %03#，则将使用从 001 到 999 这一范围内的三位数。
要点

应避免创建可能导致重复计算机名称的命名规范。避免计算机名称重复的一种方式是，使用上表所述的递增数字选项。

在定义计算机命名策略时，可通过在文本字符串中添加数值来限制计算机名称的长度。例如，要将计算机名称限制为包含用户姓氏的三个字符并附加两位递增数字，可使用以下字符串：%3Last%02#。这样，对于姓氏为 Smith 的第五个计算机用户，其相应的计算机名称将是 Smi05。

可以单独或组合使用自定义命名选项。例如，如果希望计算机名称包含用户名字的前三个字母，后跟用户姓氏的前三个字母，然后再跟随一个三位的递增数字，则可以使用字符串：%3First%3Last%03#。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 管理服务器属性


挂起设备

如果不选择自动批准设备，可以在 Windows 部署服务中使用挂起设备文件夹来批准或拒绝客户端安装。在远程安装服务 (RIS) 中，只能手动创建预留设备。Windows 部署服务通过自动添加策略，从而提供了一种更加自动化的简便方法来创建预留计算机帐户对象。

可以配置两种不同的策略类型来控制自动添加策略行为：

  • 无操作

  • 挂起

无操作

此类型为默认设置，等效于不启用自动添加策略。在效果方面，此选项表示“如果‘应答客户端’= 是，‘仅应答已知客户端’= 否，并且未找到预留设备，则不执行进一步操作”。这意味着，Windows 部署服务不会代表未知客户端请求服务创建计算机帐户。不过，它还是会应答该请求服务，原因是 PXE 应答策略指定应答所有客户端，即使未预留客户端也不例外。

挂起

使用此选项时，将在挂起设备文件夹中存放未知设备。该设备将保留在此队列中，直到发生下列四种情况之一：

  • 设备得到批准。

  • 设备遭到拒绝。

  • 达到超时值。

  • 网络启动尝试被取消。

在响应客户端初始 PXE 启动请求的 Windows 部署服务服务器上，所有置于挂起队列中的设备都将表示为挂起设备数据库中的一个条目。此临时存储位置的用途如下：

  • 为管理实用程序提供一个公共接口，以便获取服务器上所有挂起设备的列表。

  • 作为“审核跟踪”以记录已批准/已拒绝的设备。

  • 使 Active Directory 免受以下情况的影响：计算机帐户对象大小增大/变旧；当所有启动设备都自动添加到 Active Directory 并仅在被拒绝的情况下才进行删除时出现问题。

通过使用 Windows 部署服务管理工具，可以从挂起设备数据库中检索当前挂起队列中的设备列表。然后可以有选择地批准或拒绝设备。批准设备后，客户端计算机将可以继续网络启动操作。另外，将在 Active Directory 中创建一个计算机帐户对象来代表该物理设备。拒绝设备将导致物理计算机中止网络启动尝试，并将根据计算机 BIOS 启动顺序所定义的下一个设备继续启动。对于已拒绝的设备，将不在 Active Directory 中创建计算机帐户。

其他注意事项和参考

  • 若要执行此过程，您必须是帐户操作员组、域管理员组的成员，或委派了正确的权限。

  • 需要向 Windows 部署服务服务器的计算机对象委派适当的权限，才能使挂起设备策略在设备得到批准时在 AD 中成功创建计算机对象。请参阅“Windows 部署服务部署指南”，网址为 http://go.microsoft.com/fwlink/?LinkId=71130。

  • 管理服务器属性


管理 Windows 映像

可以使用 Windows 部署服务管理单元或在命令提示符处使用 WDSUTIL 来管理 Windows 映像。

  • 映像类型

  • 添加映像

  • 创建映像

  • 修改映像

  • 删除映像

  • 导出映像

  • 映像属性

  • 映像组

  • 无人参与安装文件

  • 语言包

  • 旧版映像

  • 示例无人参与安装文件


映像类型

Windows 部署服务中使用的主要映像类型为安装映像和启动映像。安装映像是使用远程安装服务 (RIS) 附带的工具创建的 Windows 映像 (WIM) 文件或旧映像。启用映像是一些 WIM 文件，其中包括安装映像（与 Windows 部署服务协同工作来安装 Windows）、捕获映像（用于捕获通过 Sysprep.exe 映像准备的、要部署到新客户端的映像）以及发现映像（用于启动非 PXE 兼容的系统以进入 Windows 部署服务服务器）。

  • 安装映像

  • 启动映像

安装映像

安装映像是操作系统映像，它们将安装在客户端计算机上，用于启动客户端计算机以进入 Windows 部署服务服务器。

  • WIM 格式。WIM 文件是一种新的文件格式，它包含一个或多个压缩的 Windows 映像。WIM 文件是以文件（而不是扇区）为基础的，这使对现有映像的更新变得更加容易。WIM 文件还使用单实例存储 (SIS) 技术，避免了 WIM 中出现重复文件。

  • RIPREP 映像。RIPREP 映像是旧 RIS 映像。无论在旧模式还是混合模式下，Windows 部署服务都能够部署 RIPREP 映像。RIPREP 映像与 HAL 和语言都相关，因而支持成本相当高。

  • RISETUP 映像。RISETUP 映像是 RIS 中的第一个映像类型。从本质上说，它们是 RIS 服务器文件共享上的 CD 目录结构（i386 目录）的一个副本。与 RIS 中的 RIPREP 映像相比，RISETUP 映像具有一个主要优点：它们与 HAL 无关。

启动映像

启动映像是包含 WDS 客户端的 Windows PE 映像，用于在客户端联系 Windows 部署服务服务器时提供初始启动菜单。

  • 安装映像是从 WDS 映像存储中导出启动映像时的默认映像类型。当客户端启动进入安装映像时，将立即调用 Windows 安装程序。

  • 在捕获通过实用程序 Sysprep.exe 准备的映像时，捕获映像可提供命令行实用程序 ImageX.exe 的一种替代方式。当客户端启动进入捕获映像时，将调用 Windows 部署服务捕获实用程序，并引导您完成捕获和添加新映像的过程。

  • 发现映像是 Windows 部署服务可以识别的启动映像，可以将它们复制到 CD 上，以便在 PXE 启动服务不可用时使用此映像。在启动进入发现映像后，将向用户显示 Windows 部署服务客户端菜单，并按照通过 PXE 启动时的相同方式继续安装过程。

其他参考

  • 管理 Windows 映像

  • 旧版映像


添加映像

可以使用 Windows 部署服务管理单元或在命令提示符处使用 WDSUTIL 添加映像。

  • 添加启动映像

  • 添加安装映像

  • 添加旧版映像

添加启动映像

使用 Windows 部署服务管理单元添加启动映像

  1. 单击以展开服务器列表。

  2. 单击以展开服务器。

  3. 右键单击“启动映像”文件夹，然后单击“添加启动映像”。

  4. 单击“浏览”以选择要添加的映像。

  5. 单击“确定”。
在命令提示符处使用 WDSUTIL 添加启动映像

  • 若要添加启动映像，请键入：

    WDSUTIL /add-image /imagefile:\\server\share\sources\boot.wim /imagetype:boot

    其中的路径是到启动映像的完整路径。
注意

要上载的映像应为 Windows Vista DVD 中的 boot.wim。还有其他可用的 WinPE 映像，例如 Windows AIK 中的映像或不能作为“安装”映像使用的其他自定义映像。

添加安装映像

使用 Windows 部署服务管理单元添加安装映像

  1. 单击以展开服务器列表。

  2. 单击以展开服务器。

  3. 单击以展开“安装映像”文件夹。

  4. 右键单击要将映像添加到其中的映像组，然后单击“添加安装映像”。

  5. 单击“浏览”以选择要添加的映像。

  6. 单击“确定”。
在命令提示符处使用 WDSUTIL 添加安装映像

  • 要添加安装映像，请键入：

    WDSUTIL /add-image /imagefile:\\server\share\sources\install.wim /image type:install

    其中的路径是到安装映像的完整路径。

添加旧版映像

可以使用旧版 RIS 工具和方法向 Windows 部署服务服务器中添加 RIS 映像。

添加旧版映像

  1. 打开“Active Directory 用户和计算机”。

  2. 在控制台树中，右键单击适用的远程安装服务 (RIS) 服务器。

  3. 单击“属性”，然后在“属性”对话框中，单击“远程安装”选项卡。

  4. 单击“高级设置”，然后单击“映像”选项卡。

  5. 单击“添加”。

  6. 单击“添加新的安装映像”，然后单击“下一步”以启动远程安装服务安装向导。

  7. 单击“下一步”，然后键入安装文件的位置。该位置可以是光盘或共享文件夹。

  8. 为新的安装映像键入文件夹名称。

  9. 输入易懂描述和帮助文本，然后单击“下一步”。

  10. 指定是希望使用新的 .osc 屏幕并备份以前的 .osc 屏幕，还是使用新的 .osc 屏幕并覆盖以前的屏幕，抑或是保留以前的 .osc 屏幕。

  11. 复查安装摘要，然后单击“完成”。

其他注意事项和参考

  • 若要执行此过程，您必须是本地计算机上管理员组的成员，或委派了正确的权限。如果计算机已加入到域中，则域管理员组的成员可以执行此过程。作为一项安全最佳做法，请考虑使用“运行方式”来执行此过程。

  • 若要打开“Active Directory 用户和计算机”，请单击“开始”，单击“运行”，键入 dsa.msc，然后单击“确定”。

  • 管理 Windows 映像


创建映像

可以使用 Windows 部署服务创建安装映像和启动映像，包括捕获映像和发现映像。捕获映像用于从使用 Sysprep.exe 准备的系统中创建新安装映像并将它们添加到映像存储中。发现映像为非 PXE 兼容的网络适配器提供了一种访问 WDS PXE 服务器的方式。还可以使用 Windows 部署服务导出安装启动 WIM。

通过 WIM 文件创建可启动媒体需要安装 Windows AIK。有关详细信息，请参阅“Windows Automated Installation Kit (WAIK) User's Guide for Windows Vista（用于 Windows Vista 的 Windows 自动安装包 (WAIK) 用户指南）”(http://go.microsoft.com/fwlink/?LinkID=53552)。

  • 创建安装映像

  • 创建捕获映像

  • 创建发现映像

  • 创建启动媒体

创建安装映像

安装映像是从 Windows 操作系统的参考安装生成的，当使用 Windows 部署服务安装 Windows 时，系统会将其部署在客户端桌面。参考安装可以是标准 Windows 安装，也可以在创建映像之前根据特定的环境或用途进行配置。

创建安装映像

  1. 创建参考计算机。

  2. 在参考计算机的命令提示符处，将目录更改为 \Windows\system32\Sysprep 或包含 Sysprep.exe 和 Setupcl.exe 的目录。

  3. 键入 sysprep /OOBE /Generalize /Reboot。

  4. 参考计算机重新启动时，按 F12。

  5. 在“Windows 启动管理器”中，选择适当捕获映像的启动文件。

  6. 在“映像捕获向导”欢迎页上，单击“下一步”。

  7. 在“映像捕获源”页上，使用“要捕获的卷”下拉控件选择适当的卷，然后为映像提供一个名称和相关说明。单击“下一步”继续。

  8. 在“映像捕获目标”页上，单击“浏览”并浏览至要存储已捕获映像的位置。

  9. 在“文件”“名称”文本框中，使用 .WIM 文件名后缀为映像键入一个名称，然后单击“保存”。

  10. 单击“将映像上载至 WDS 服务器”。

  11. 键入 WDS 服务器的名称，然后单击“连接”。

  12. 如果系统提示输入凭据，请提供一个有足够权限连接到 WDS 服务器的帐户的用户名及密码。

  13. 使用“映像组”下拉控件，选择将在其中存储映像的映像组。

  14. 单击“完成”。
注意

步骤一中的目录结构仅对 Windows Server“Longhorn” 和 Windows Vista 有效。对于 Windows 2003 和 Windows XP，请使用 Deploy.cab 中适当的 Sysprep 版本。

注意

步骤二中的这一语法仅对 Windows Server“Longhorn” 和 Windows Vista 有效。通过键入 sysprep /? 检查语法是否适于您的 Windows 版本

创建捕获映像

捕获映像用于捕获使用 Sysprep.exe 准备以作为安装映像进行部署的 Windows 映像。捕获映像是启动映像捕获向导的启动映像。捕获映像首先保存在文件中，然后再添加回映像存储。

使用 Windows 部署服务创建捕获映像

  1. 展开“启动映像”文件夹。

  2. 右键单击将用作捕获映像的映像。

  3. 单击“创建捕获启动映像”。

  4. 为捕获映像选择一个名称和说明。

  5. 为新文件选择一个位置和名称。

  6. 单击“确定”创建捕获映像。

  7. 单击“完成”。

  8. 右键单击“启动映像”文件夹。

  9. 单击“添加启动映像”。

  10. 通过浏览选择新的捕获映像，然后单击“下一步”。

  11. 更新捕获映像的名称和说明（可选），然后单击“下一步”。

  12. 单击“下一步”。

  13. 单击“完成”。
使用 WDSUTIL 创建捕获映像

  1. WDSUTIL 是 Windows 部署服务命令行管理工具，需要有提升的特权才能运行：依次单击“开始”、“所有程序”、“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符处，键入：

    WDSUTIL /new-captureimage /image: boot_image /architecture:x86 /filepath:capture_image

    其中，boot_image 是要用于创建捕获映像的启动映像的名称，capture_image 是新的捕获映像的文件路径和文件名。

  3. 在命令提示符处，键入：

    WDSUTIL /add-image /imagefile: capture_image /imagetype:boot

    其中，capture_image 是要添加到映像存储中的捕获映像的文件路径和文件名。
注意

在命令提示符处键入 WDSUTIL /? 可获得有关 WDSUTIL 的帮助。

创建发现映像

发现映像用于通过 Windows 部署服务将 Windows 操作系统部署到不支持 PXE 启动的计算机上。发现映像是启动 Windows 部署服务发现向导的启动映像。发现映像将保存到文件中，转换为 ISO 格式，然后再刻录到 CD 或 DVD 上。

使用 Windows 部署服务创建发现映像

  1. 展开启动映像文件夹。

  2. 右键单击将用作发现映像的映像。

  3. 单击“创建发现启动映像”。

  4. 为发现映像选择一个名称和说明。

  5. 为新文件选择一个位置和名称，并使用 .wim 文件扩展名。

  6. 单击“确定”创建捕获映像。

  7. 单击“完成”。
使用 WDSUTIL 创建发现映像

  1. WDSUTIL 是 Windows 部署服务命令行管理工具，需要有提升的特权才能运行：依次单击“开始”、“所有程序”、“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符处，键入：

    WDSUTIL /new-discoverimage /image: boot_image /architecture:x86 /filepath:discover_image

    其中，boot_image 要用于创建发现映像的启动映像的名称，discover_image 是新发现映像的文件路径和文件名。
注意

在命令提示符处键入 WDSUTIL /? 可获得有关 WDSUTIL 的帮助。

创建启动媒体

创建可启动媒体

  1. 安装 Windows Automated Installation Kit。

  2. 打开命令提示符更换到 PETools 文件夹。

    Cd C:\Program Files\Windows AIK\Tools\PETools

  3. 要创建 WinPE 编译环境，请键入：

    CopyPE <architecture> C:\Winpe

  4. 复制上一步中创建的发现映像：

    Copy /y c:\boot.wim c:\Winpe\ISO\Sources

  5. 改回 PETools 文件夹。

    Cd C:\Program Files\Windows AIK\Tools\PETools

  6. 创建可启动的 ISO 映像：

    Oscdimg -n -bc:\winpe\boot\etfsboot.com c:\winpe c:\winpe.iso

  7. 使用可以创建 CD 或 DVD 的实用程序将 ISO 映像转移至适当的媒体。
注意

此过程需要使用第三方 CD 复制实用程序。

其他参考

  • 管理 Windows 映像

  • 旧版映像

  • 导出映像

  • Windows 自动安装包 http://go.microsoft.com/fwlink/?LinkID=53552


修改映像

可以通过修改映像来添加文件或驱动程序，而无需创建新映像。这些过程对于启动映像或安装映像都相似，但这两种映像类型使用的工具集和语法会有所不同。有关修改 WIM 映像的详细信息，请参阅“Windows Automated Installation Kit (WAIK) User's Guide for Windows Vista”[用于 Windows Vista 的 Windows 自动安装包 (WAIK) 用户指南，http://go.microsoft.com/fwlink/?LinkID=53552]。

  • 修改启动映像

  • 修改安装映像

修改启动映像

修改启动映像

  1. 找到要维护的映像，然后将其标记为脱机。如果您使用 Windows 部署服务管理单元执行此操作，请右键单击该映像，然后选择“禁用”。此操作允许现有安装继续进行，但新客户端将无法枚举该映像。

  2. 导出映像。

  3. 维护映像。

  4. 将映像添加到服务器。有两种方法可实现此目的：

    1. 将新维护的版本作为新映像添加到同一映像组中。然后可以删除旧映像（将不会枚举旧映像，因为它处于脱机状态）。

    2. 使用新维护的版本替换现有的映像（假设使用该映像的所有安装都已完成）。（推荐执行此步骤。）

修改安装映像

修改安装映像

  1. 找到要维护的映像，然后将其标记为脱机。如果您使用 Windows 部署服务管理单元执行此操作，请右键单击该映像，然后选择“禁用”。此操作允许现有安装继续进行，但新客户端将无法枚举该映像。

  2. 导出映像。

  3. 维护映像。

  4. 将映像添加到服务器。有两种方法可实现此目的：

    1. 将新维护的版本作为新映像添加到同一映像组中。然后可以删除旧映像（将不会枚举旧映像，因为它处于脱机状态）。

    2. 使用新维护的版本替换现有的映像（假设使用该映像的所有安装都已完成）。（推荐执行此步骤。）

其他参考

  • 管理 Windows 映像

  • Windows Automated Installation Kit (WAIK) User's Guide for Windows Vista [用于 Windows Vista 的 Windows 自动安装包 (WAIK) 用户指南，http://go.microsoft.com/fwlink/?LinkID=53552]


删除映像

可以使用 Windows 部署服务管理单元或在命令提示符处使用 WDSUTIL 删除映像。

  • 删除启动映像

  • 删除安装映像

删除启动映像

使用 Windows 部署服务管理单元删除启动映像

  1. 展开包含要删除的映像的服务器。

  2. 单击以选择“启动映像”。

  3. 在操作窗格中，右键单击该映像，然后单击“删除映像”。

  4. 在“确认”对话框中，单击“是”以删除映像。
在命令提示符处使用 WDSUTIL 删除启动映像

  • 键入 WDSUTIL /Remove-Image /Image:ImageName /ImageType:boot

    /Architecture: Arch，其中 ImageName 是映像的名称，Arch 是映像的体系结构（x86 或 x64）。

删除安装映像

使用 Windows 部署服务管理单元删除安装映像

  1. 展开包含要删除的映像的服务器。

  2. 单击以选择“安装映像”。

  3. 单击以选择包含该映像的映像组。

  4. 在操作窗格中，右键单击该映像，然后单击“删除映像”。

  5. 在“确认”对话框中，单击“是”以删除映像。
在命令提示符处使用 WDSUTIL 删除安装映像

  • 键入 WDSUTIL.exe /verbose /Remove-Image /Image:"Windows Vista with Office"

    /Server:MyWDSServer /ImageType:install /ImageGroup:ImageGroup1

    /Filename:install.wim

其他注意事项和参考

  • 若要执行此过程，您必须是本地计算机上管理员组的成员，或委派了正确的权限。如果计算机已加入到域中，则域管理员组的成员可以执行此过程。作为一项安全最佳做法，请考虑使用“运行方式”来执行此过程。

  • 管理 Windows 映像


导出映像

可以导出映像，以便对映像进行更改，例如添加驱动程序或更新。还可以在创建可启动媒体时导出启动映像。

  • 导出启动映像

  • 导出安装映像

导出启动映像

使用 Windows 部署服务管理单元导出启动映像

  1. 单击以展开服务器列表。

  2. 单击以展开服务器。

  3. 单击以展开“启动映像”文件夹。

  4. 右键单击映像，然后单击“导出映像”。

  5. 键入映像的路径和文件名，然后单击“保存”。
在命令提示符处使用 WDSUTIL 导出启动映像

  • 要添加启动映像，请键入：

    WDSUTIL /Export-Image /Image: ImageName /ImageType:Boot

    /Architecture:x86 /DestinationImage /FilePath: FilePath。

    其中，ImageName 是原始映像的名称，FilePath 是导出的启动映像的完整路径和名称。

导出安装映像

使用 Windows 部署服务管理单元导出安装映像

  1. 单击以展开服务器列表。

  2. 单击以展开服务器。

  3. 单击“安装映像”文件夹。

  4. 单击以展开映像组。

  5. 右键单击映像，然后单击“导出映像”。

  6. 键入映像的路径和文件名，然后单击“保存”。
在命令提示符处使用 WDSUTIL 导出安装映像

  • 要导出安装映像，请键入：

    WDSUTIL.exe /Export-Image /Image: ImageName

    /ImageType:Install /DestinationImage /FilePath: FilePath。

    其中，ImageName 是原始映像的名称，FilePath 是导出的启动映像的完整路径和名称。

其他注意事项和参考

  • 若要执行此过程，您必须是本地计算机上管理员组的成员，或委派了正确的权限。如果计算机已加入到域中，则域管理员组的成员可以执行此过程。作为一项安全最佳做法，请考虑使用“运行方式”来执行此过程。

  • 管理 Windows 映像


映像属性

映像属性页提供了有关映像的详细说明。启动映像的映像属性页包含“常规”和“版本”选项卡。安装映像的映像属性页添加了“安全”选项卡。

除查看属性外，属性页还允许重命名映像和更改映像说明。对于安装映像，可以启用无人参与安装，也可以选择“安全”选项卡来修改映像的安全设置。

查看映像属性

可以使用 Windows 部署服务管理单元或在命令提示符处使用 WDSUTIL 来查看启动映像属性。

使用 Windows 部署服务管理单元查看映像属性

  1. 右键单击映像，然后单击“属性”。

  2. 通过单击选项卡来选择要查看的属性。
通过在命令提示符处使用 WDSUTIL 查看映像属性

  • 键入 WDSUTIL.exe /Get-Image /Image:映像名称 /ImageType:映像类型 /Architecture:体系结构。

    其中，其中映像名称是映像的名称，映像类型是 boot 或 install，体系结构是 x86 或 x64。

映像属性

下表列出映像的属性，并对每个属性提供了简短说明。

“常规”选项卡

属性 | 说明
映像名称 | 映像名称在文本框中提供。可以在此处更改映像名称，并使用“确定”或“应用”更新映像。
映像类型 | 指示映像是启动映像还是安装映像。
状态 | 指示映像处于联机状态还是脱机状态。
体系结构 | 指示处理器体系结构是 x86 还是 x64。
说明 | 映像说明在文本框中提供。可以在此处更改映像名称，并使用“确定”或“应用”更新映像。
映像组 | 当前存储此映像的映像组。
文件名 | 映像的文件名，包括文件扩展名。
大小 | 未压缩映像的大小，不必是映像或包含映像的 WIM 的实际大小。
创建日期 | 映像的创建日期。
修改日期 | 映像的上次修改日期。
HAL 类型 | 仅安装映像 - 指示创建映像时使用的 HAL 类型。
无人参与模式 | 选中此框，然后选择无人参与安装文件，可使映像执行无人参与安装。

“版本”选项卡

属性 | 说明
映像版本 | Windows 主版本和内部版本号。
内部名称 | 映像的原始名称。
语言 | WIM 文件的原始语言。
原始文件名 | WIM 文件的原始名称。
产品名称 | 映像中包含的操作系统的 Microsoft 产品名称。
产品系列 | 映像中包含的操作系统映像的产品系列。
Service Pack 级别 | Windows 映像的 Service Pack 级别。

“安全”选项卡

属性 | 说明
组或用户名 | 通过在此对话框中添加或删除用户，可以更改有权访问映像的人员。
管理员权限 | 可以通过此对话框修改用户的权限，包括为其授予特殊权限。
高级 | 通过单击“高级”按钮，可以获得映像文件的所有权、审核映像文件的访问权或修改映像文件的继承权限。

其他参考

  • 管理 Windows 映像


映像组

映像组是一个由共享公共文件资源和安全的 WIM 映像文件构成的集合。映像组是一个服务边界，因为向映像组内的映像提供服务的操作（例如，应用修补程序、Service Pack 或更新文件）将需要对该组具有独占的访问权限。即使每个映像的映像元数据都位于单独的物理 WIM 文件中，但仍可以跨映像组（单实例）共享文件资源。映像组包含两种文件类型：

  • Res.rwm – 包含 Install.wim、Install2.wim 和 WinXP.wim 中定义的映像的文件流。请注意，每个映像组都拥有自己的 Res.rwm 文件。

  • Install.wim – 包含描述操作系统映像内容的映像元数据。映像的实际文件资源位于 Res.rwm 中。

每个映像组都会当映像组中添加第一个映像时创建 Res.rwm 文件。众所周知，Res.rwm 仅存放 WIM 资源，所有文件的所有资源都位于 Res.rwm 中。.rwm 是经过重命名的 .wim 文件，用于区分仅资源 .wim 文件和元数据 .wims 并加速映像枚举。原因是映像枚举仅作用于 .wim 文件并将跳过 Res.rwm 文件。

WIM 文件中的数据是单实例数据，因此重复的文件将仅存储一次，这样便极大地减少了磁盘上用于映像组中映像的存储区大小。

其他参考

  • 管理 Windows 映像


无人参与安装文件

通过 Windows 部署服务，您可以自动处理 Windows 部署服务客户端及后续阶段的 Windows 安装。此两阶段方法是通过使用两个不同的无人参与安装文件实现的。Windows 部署服务无人参与安装文件存储在 Windows 部署服务服务器的 \WDSClientUnattend 文件夹中，用于自动处理第一个安装阶段。用于在 Windows 安装期间配置无人参与安装选项的文件存储在每个映像文件夹的子文件夹（$OEM$ 结构或 \Unattend）中，此文件可自动处理第二到第七个安装阶段。

无论要自动处理哪个安装阶段，都需要创建 Unattend.xml 文件、将其复制到适当的位置并分配使用。对无人参与安装文件的分配可以在服务器级别或客户端级别执行。服务器级别分配可以进一步按体系结构细分，以便为 x86 和 x64 客户端使用不同的设置。客户端级别的分配会覆盖服务器级别的设置。

注意

Windows 部署服务管理工具仅支持为 Windows Vista 和 Windows Server“Longhorn” 映像设置安装映像的无人参与文件。下级映像要求使用现有的 Sysprep.inf 文件并手动创建一个 $OEM$ 目录结构。

通过下列步骤配置无人参与安装：

  1. 根据您要配置的是 Windows 部署客户端、Windows 安装还是旧安装，创建一个适当的无人参与文件。请注意，Windows AIK 中包含的 Windows 系统映像管理器提供了一个用于编写无人参与文件的极佳环境。

  2. 将无人参与文件与映像或计算机类型相关联。

下列过程说明如何配置无人参与安装。第一个过程说明按体系结构配置 Windows 部署服务客户端的无人参与选项的过程，下一过程说明如何按计算机配置无人参与选项。最后一个过程说明如何配置 Windows 安装的无人参与选项。

  • Windows 部署服务的无人参与文件

  • Windows 安装的无人参与文件

配置 Windows 部署服务的无人参与文件

使用 Windows 部署服务管理单元按体系结构关联 WDS 客户端无人参与文件

  1. 创建一个 Unattend.xml 文件，使其设置适用于 Windows 部署服务客户端。

  2. 将 XML 文件复制到 RemoteInstall\WDSClientUnattend 中。

  3. 打开 Windows 部署服务管理单元。

  4. 展开左窗格中的列表，以显示“服务器”列表。

  5. 右键单击包含无人参与文件要关联到的 Windows Vista 或 Windows Server“Longhorn” 映像的 Windows 部署服务服务器，然后单击“属性”。

  6. 单击“客户端”选项卡。

  7. 单击“启用无人参与安装”。

  8. 单击适当体系结构旁边的“浏览”按钮。

  9. 通过浏览选择无人参与文件，然后单击“打开”。

  10. 单击“确定”。

  11. 若要关闭“服务器属性”，请单击“确定”。
使用 WDSUTIL 按体系结构关联 WDS 客户端无人参与文件

  1. WDSUTIL 是 Windows 部署服务命令行管理工具，需要有高特权才能运行：单击“开始”，单击“所有程序”，单击“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符符处，键入：

    WDSUTIL /set-server /wdsunattend /policy:enabled /file:文件路径 /architecture:x86

    其中，文件路径 是无人参与文件的路径名和文件名，体系结构是要自动处理的客户端的体系结构。
注意

在命令提示符符处键入 WDSUTIL /? 可获得有关 WDSUTIL 的帮助。

使用 WDSUTIL 按计算机关联 Windows 部署服务客户端无人参与文件

  • 在命令提示符符处，键入：

    WDSUTIL /set-device /device: 计算机名 /ID:GUID 或 MAC 地址 /WdsClientUnattend:相对路径

    其中，相对路径是从 REMINST 共享到包含 WdsClientUnattend.xml 的文件夹的路径。

配置 Windows 安装的无人参与文件

使用 Windows 部署服务管理单元将 Windows 安装无人参与文件关联到映像

  1. 在 Windows 部署服务管理单元中，单击以展开包含 Windows Vista 或 Windows Server“Longhorn” 映像的映像组。

  2. 右键单击无人参与文件要关联到的映像，然后单击“属性”。

  3. 单击“允许在无人参与模式下安装映像”。

  4. 单击“选择文件”。

  5. 输入名称和路径，或通过浏览选择无人参与文件，然后单击“打开”。

  6. 单击“确定”。

  7. 若要关闭“映像属性”页，请单击“确定”。
使用 WDSUTIL 将 Windows 安装无人参与文件关联到映像

  1. WDSUTIL 是 Windows 部署服务命令行管理工具，需要有高特权才能运行：单击“开始”，单击“所有程序”，单击“附件”，右键单击“命令提示符”，然后单击“特权运行”。

  2. 在命令提示符符处，键入：

    WDSUTIL /set-image /image: 映像名 /imagetype:install /imagegroup:映像组名 /unattendfile:无人参与文件

    其中，映像名是无人参与文件要关联到的映像的名称，映像组名是包含映像文件的映像组的名称，无人参与文件是要与映像关联的无人参与文件的路径和文件名。
注意

有关无人参与安装的详细信息，请参阅 Windows AIK 产品文档。

将 Sysprep.inf 文件与下级映像关联

  1. 在命令提示符符处，将目录更改到包含下级映像的映像组。

  2. 在包含旧映像的映像组中，创建一个目录，使其与映像要关联到的 WIM 同名：

    Md C:\RemoteInstall\Images\ 映像组名 \ 映像文件名

  3. 创建一个 $OEM$ 目录结构：

    Mc C:\RemoteInstall\Images\ 映像组名 \ 映像文件名 \$OEM$

  4. 将适合此映像的 sysprep.inf 文件复制到 $OEM$ 目录中：

    Copy C:\Sysprep.inf C:\RemoteInstall\Images\ 映像组名 \ 映像文件名 \$OEM$

  5. 按照 $OEM$ 的约定，根据需要在适当的情况下添加文件或进行其他更改。

  6. 应用映像后，将复制整个 $OEM$ 目录并将其内容应用于该映像。
注意

有关 Sysprep.inf 和 $OEM$ 目录的详细信息，请参阅“Designing Automated Setup Tasks”（设计自动化安装任务，http://go.microsoft.com/fwlink/?LinkId=66136）。

其他参考

  • 管理 Windows 映像


语言包

可以将多个语言包与单个映像关联在一起，以减少需要维护的映像数目。若要使用语言包，请创建适当的目录结构并复制语言包。

将语言包与映像相关联

  1. 在包含该映像的映像组文件夹中，创建一个与该映像文件同名的目录。在该文件夹中，创建一个名为 langpacks 的目录。如果映像组名为 Vista 且映像名为 Install，请键入：

    md c:\remoteinstall\images\vista\install\langpacks

  2. 在 langpacks 目录中，为每个要安装的语言包均创建一个目录。若要创建日语语言的 langpacks 目录，请键入：

    md c:\remoteinstall\images\vista\install\langpacks\ja-jp

  3. 将日语语言包复制到 C:\Remoteinstall\images\vista\install\langpacks\ja-jp。

其他注意事项

  • 只有 Windows Vista 和 Windows Server“Longhorn” 操作系统才支持语言包。

其他参考

  • 管理 Windows 映像


旧版映像

对于旧 RISETUP 和 RIPREP 映像，可通过旧的远程安装服务 (RIS) RISETUP 和 RIPREP 实用程序以及 Active Directory 用户和计算机管理单元进行管理。通过使用 RIS 工具或使用 Windows 部署服务管理工具，可查看映像列表。

  • RISETUP 映像

  • RIPREP 映像

RISETUP 映像

通过使用以下过程，可以将现有的 RISETUP 映像转换为本机 WIM 映像。

将 RISETUP 映像转换为 WIM 映像

  1. 启动基准计算机以进入 OSChooser 菜单。

  2. 选择安装适当的映像。

  3. 使用 Sysprep.exe 准备映像。

  4. 使用捕获映像保存映像并将其添加到 Windows 部署服务服务器中。

其他注意事项

  • 由于 Windows Vista 之前的 Windows 操作系统都与硬件抽象层 (HAL) 相关，因此每个 HAL 类型都需要使用单独的映像。

其他参考

  • 管理 Windows 映像

  • 远程安装服务 (http://go.microsoft.com/fwlink/?LinkId=71138)

RIPREP 映像

RIPREP 映像是使用 Sysprep.exe 准备的映像，它不具有完全填充的关键设备数据库。RIPREP 映像将关键设备数据库存储在合适的 RISETUP 映像中。

可以使用两个过程将 RIPREP 映像转换为 WIM 格式。

  • 使用转换实用程序将映像从 RIPREP 转换为 WIM

  • 将 RIPREP 映像部署到基准计算机，然后使用新的 WDS 映像捕获实用程序将该映像捕获到 WDS 服务器

转换 RIPREP 映像

将服务器升级到 Windows 部署服务后，可以使用下列过程之一将 RIPREP 映像转换为 WIM。

使用 Windows 部署服务管理单元将 RIPREP 映像转换为 WIM

  1. 单击以展开“旧映像”。

  2. 右键单击要转换的映像，然后单击“转换映像”。

  3. 完成映像转换后，将该映像添加到适当的映像组中。
在命令提示符处使用 WDSUTIL 转换映像

  1. 键入 WDSUTIL /convert-riprepimage /filepath:file_path1 /destinationimage /filepath:file_path2，其中 file_path1 是 .sif 文件的完整路径，file_path2 是新的 WIM 文件的完整路径。

  2. 键入 WDSUTIL /add-image /imagefile:file_path2 /image type:install
使用捕获实用程序将 RIPREP 映像转换为 WIM 映像

  1. 启动基准计算机以进入 OSChooser 菜单。

  2. 选择安装适当的映像。

  3. 使用 Sysprep.exe 准备映像。

  4. 使用捕获映像保存映像并将其添加到 Windows 部署服务服务器中。
要点

必须对 RIPREP 映像具有完全控制权限才能完成转换过程。如果不具有完全控制权限，转换将失败，错误代码为 0x522。

其他注意事项

  • 如果在 Windows Server 2003 上运行 Windows 部署服务，则可以使用任何一种转换方法。如果在 Windows Server“Longhorn” 上运行 Windows 部署服务，则只能使用转换实用程序。这是因为 Windows Server“Longhorn” Windows 部署服务服务器不再支持 OSChooser，因此无法从该服务器部署 RIPREP 映像。

  • 作为一项最佳做法，在转换映像之前，最好将映像和映像文件复制到临时目录中。这样，如果此转换过程失败，或者需要回滚到原始映像，原始映像仍保留未修改。

  • RIPREP 转换过程需要来自以下两个 DLL 的 API：drvstore.dll 和 cmiv2.dll。在 Windows Vista 和 Windows Server“Longhorn” 计算机上，这些二进制文件作为安装的一部分存在。在 Windows Server 2003 和 Windows XP 上，不存在这些二进制文件。为在 Windows Server 2003 上执行 RIPREP 转换管理任务，必须执行下列步骤：

    1. 将 Windows AIK 安装到 Windows Server 2003 WDS 服务器上。Windows AIK 包含必要的支持文件 drvstore.dll 和 cmiv2.dll，并且会默认安装这些文件。

    2. 确保文件路径中包含这些文件。

  • 在 Windows Vista 之前，Sysprep 映像都与 HAL 相关。每个 HAL 类型都需要使用单独的映像

其他参考

  • 管理 Windows 映像

  • 远程安装服务 (http://go.microsoft.com/fwlink/?LinkId=71138)


示例无人参与安装文件

可以使用无人参与文件自动化安装的许多方面。使用这些示例可帮助解决安装中的问题，或由此开始创建自己的自定义无人参与安装文件。

  • 客户端无人参与文件

  • 映像无人参与文件

客户端无人参与安装文件

通过此无人参与安装文件，您可使用 Windows 部署服务客户端感受全面自动化的安装体验。可以使用文本编辑器将示例文件另存为 XML 文件。

<?xml version="1.0" ?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

<WindowsDeploymentServices>

<Login>

<WillShowUI>OnError</WillShowUI>

<Credentials>

<Username>username</Username>

<Domain>wds-dom</Domain>

<Password>my_password</Password>

</Credentials>

</Login>

<ImageSelection>

<WillShowUI>OnError</WillShowUI>

<InstallImage>

<ImageName>Windows Vista with Office</ImageName>

<ImageGroup>ImageGroup1</ImageGroup>

<Filename>Install.wim</Filename>

</InstallImage>

<InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

</ImageSelection>

</WindowsDeploymentServices>

<DiskConfiguration>

<WillShowUI>OnError</WillShowUI>

<Disk>

<DiskID>0</DiskID>

<WillWipeDisk>false</WillWipeDisk>

<ModifyPartitions>

<ModifyPartition>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Letter>C</Letter>

<Label>TestOS</Label>

<Format>NTFS</Format>

<Active>true</Active>

<Extend>false</Extend>

</ModifyPartition>

</ModifyPartitions>

</Disk>

</DiskConfiguration>

</component>

<component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

<SetupUILanguage>

<WillShowUI>OnError</WillShowUI>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<UILanguage>en-US</UILanguage>

</component>

</settings>

</unattend>

其他参考

  • 管理 Windows 映像

  • 无人参与安装文件

  • 旧版映像

示例映像无人参与安装文件

此文件可设置产品密钥，并帮助您成功完成域加入操作。可以使用文本编辑器将示例文件另存为 XML 文件。

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="specialize">

<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<Identification>

<UnsecureJoin>true</UnsecureJoin>

</Identification>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<ProductKey>XXXX-XXXX-XXXX-XXXX-XXXX</ProductKey>

</component>

</settings>

</unattend>

其他参考

  • 管理 Windows 映像

  • 无人参与安装文件

  • 旧版映像


Windows 部署服务疑难解答

本节列出了使用 Windows 部署服务时可能遇到的一些常见问题。

您遇到了哪些问题？

  • 我的基于 x64 的客户端在启动映像选择页上不显示任何基于 x64 的映像。

  • 我的 x64 客户端计算机已被检测为 x64，但未能成功启动默认映像。

  • 我的计算机能够加载启动映像，但无法访问安装映像。

  • 我已创建了无人参与安装文件，但当安装完成后，我的客户端计算机未能加入到域中。

  • Windows 部署服务捕获向导不能识别包含要捕获的卷的磁盘驱动器。

    注意

    在进行故障排除时，一个好的方法是查看由 Windows 部署服务生成的事件日志。Windows 部署服务的事件日志项位于应用程序事件日志的下列源下：BNLSVC、WDSPXE、WDSIMGSRV 和 WDSServer。

我的基于 x64 的客户端在启动映像选择页上不显示任何基于 x64 的映像

很多基于 x64 的系统 BIOS 在启动过程中不会准确地将计算机识别为 x64。如果 Windows 部署服务不能将系统识别为 x64，将仅显示 x86 映像。您可以在命令提示符处键入 WDSUTIL /set-server /architecturediscovery:yes 来强制 Windows 部署服务服务器识别 x64 计算机。

我的 x64 客户端计算机已被检测为 x64，但未能成功启动默认映像。

如果基于 x64 的系统可通过 PXE 启动，但未找到基于 x64 的映像，它将无法完成启动过程。请检查 Windows 部署服务服务器中是否已添加了 x64 启动（和安装）映像。另一种方法是，您可以强制所有 X64 客户端仅接收 x86 启动文件，方法是将 x64 客户端的默认启动程序配置为使用适当的网络启动程序，例如 \RemoteInstall\boot\x86 中的 Pxeboot.com。

我的计算机能够加载启动映像，但无法访问安装映像。

启动映像可能未包含您的计算机所需的网络驱动程序。按 Shift-F10 以打开命令窗口，然后键入 IPConfig。如果未报告任何 IP 地址和子网掩码，则表明尚未启动网络连接，且可能不存在网络驱动程序。请查看修改映像中的步骤以及 http://go.microsoft.com/fwlink/?LinkID=53552 上的 Windows AIK 文档。

我已创建了无人参与安装文件，但当安装完成后，我的客户端计算机未能加入到域中。

此错误的常见原因是映像无人参与文件的格式设置不正确。若要确认您的文件是否具有正确的格式，请查看无人参与安装文件或使用示例无人参与安装文件中的示例无人参与文件。

此错误的另一个常见原因是加入域期间发生权限错误。请在 domainjoininformation 下的 \Windows\panther\setupact.log 中检查此错误。请根据该日志文件中的信息执行适当的纠正操作。

Windows 部署服务捕获向导不能识包含要捕获的卷的磁盘驱动器。

如果 Windows 部署服务映像捕获向导未找到使用 Sysprep.exe 准备的有效映像，它便不会将驱动器报告为可用。请重新安装目标操作系统，并使用 Sysprep.exe 准备要捕获的映像。有关进一步信息，请查看创建映像和旧版映像。


Windows 部署服务的资源

有关 Windows 部署服务的详细信息，请参阅下列 Microsoft 网站中的信息。

  • 有关预留客户端计算机的详细信息，请参阅“Prestage client computers（预留客户端计算机）”(http://go.microsoft.com/fwlink/?LinkId=50166)。

  • 有关 Sysprep.inf 和 $OEM$ 目录的详细信息，请参阅“Designing Automated Setup Tasks（设计自动化安装任务）”(http://go.microsoft.com/fwlink/?LinkId=66136)。

  • 有关本文档的最新版本，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=66145)。

  • 如果需要获得产品支持，请访问 Microsoft Connect 网站 (http://go.microsoft.com/fwlink/?LinkId=49779)。

  • 若要访问 Windows 部署服务的新闻组，请按照 Microsoft Connect 网站 (http://go.microsoft.com/fwlink/?LinkId=50067) 上提供的说明操作。

  • 有关 Windows AIK 的详细信息，请参阅“Windows Automated Installation Kit (WAIK) User's Guide for Windows Vista（用于 Windows Vista 的 Windows 自动安装包 (WAIK) 用户指南）”(http://go.microsoft.com/fwlink/?LinkID=53552)。

  • 有关部署 Windows 部署服务的详细信息，请参阅“Deploying Windows Vista（部署 Windows Vista）”(http://go.microsoft.com/fwlink/?LinkId=71130)。

  • 有关远程安装服务 (RIS) 的详细信息，请参阅“Remote Installation Services（远程安装服务）”(http://go.microsoft.com/fwlink/?LinkId=71138)。

  • 有关 Microsoft Solution Accelerator for Business Desktop Deployment 2007 的详细信息，请访问 http://go.microsoft.com/fwlink/?LinkId=71137。